Objective:

The IT Workshop for engineers is a 6 training lab course spread over 90 hours. The modules include training on PC Hardware, Internet, World Wide Web and Productivity tools including Word, Excel, PowerPoint and Publisher.

PC Hardware introduces the students to a personal computer and its basic peripherals, the process of assembling a PC, installation of System Software MS-Windows, Linux and the required device drivers. In addition hardware and software level troubleshooting process, tips and tricks would be covered.

Internet & WWW module introduces the different ways of hooking the PC on to the internet from home and workplace effectively usage of the internet. Usage of web browsers, e-mails, news groups and discussion forums would be covered. In addition, awareness of cyber hygiene, i.e., protecting the personal computer from getting infected with the viruses, worms and other cyber attacks would be introduced.

Prepared By:
K. Ravi Chythanya,
Assistant Professor,
Department of Information Technology,
Sree Chaitanya College of Engineering,
Karimnagar.
HARDWARE
INTRODUCTION TO COMPUTER:

Computer is an electronic device which takes the input information from the input device and generates the output information and it will be displayed on the output.

It enables arithmetic computations, data processing, information management (storage) and knowledge reasoning in an efficient manner.

The word computer is derived from the word **compute which means ‘to calculate’**. So a computer generally considered to be calculating device that perform operations at very faster rates.

BLOCK DIAGRAM OF COMPUTER

![Block Diagram of Computer](image)

Basically the computer system has three major components. These are

- System Unit
  - Central Processing Unit (Processor)
  - Memory Unit. (Main memory and Auxiliary storage).
- Input Unit.
- Output Unit.
TASK 1:

Identification of the peripherals of a computer, components in a CPU and its functions. Draw the block diagram of the CPU along with the configuration of each peripheral.

Aim: To identify the computer hardware parts

Procedure:

1. Cabinet:
   
a. It is used to install all hardware devices like (mother board, SMPS, HDD, CD ROM, FDD)
   
b. It has Start, Restart Button, Led’s, Audio and USB Connecters are available at front side.

2. Monitor:
   
a. Monitor of a computer is like a television screen.
   
b. It displays text characters and graphics in colors or in shades of grey.
   
c. The monitor is also called as screen or display or CRT (cathode ray tube). In the monitor the screen will be displayed in pixels format.
      i. 800 by 600 pixels
      ii. 1024 by 768 pixels
   
d. [Monitor Image]

3. Key Board:
   
a. Key board is like a type writer, which contains keys to feed the data or information into the computer
   
b. Keyboards are available in two modules. These are
      i. standard key board with 83-88 keys
      ii. enhanced key board with 104 keys or above
   
   [Key Board Image]
4. **Mouse:**
   a. Every mouse has one primary button (left button) and one secondary button (right button).
   b. The primary button is used to carry out most tasks, whereas the secondary button is used in special cases you can select commands and options.

5. **Printer:**
   a. A device that prints images (numbers, alphabets, graphs, etc...) on paper is known as Printer.
   b. We have different types of printers to take printouts. These are as follows:
      i. Dot matrix printer
      ii. Inkjet printer
      iii. Laser printer

6. **Speakers:**
   a. Speakers make your system much more delightful to use entertain you while you are working on computer.
7. **Scanner**:
   
a. Scanner used to scan images and text

8. **System board/Motherboard**
   
a. This is the major part of the PC hardware
b. It manages all transactions of data between CPU peripherals.
c. which holds the Processor, Random Access Memory and other parts, and has slots for expansion cards
d. It is rectangle shape

9. **Socket 478**:
   
a. It use 478 – PIN MICROPGA package it is used installing CPU
b. It is square type design.

10. **CPU**
    
a. The central processing unit contains the heart of any computer, the processor. The processor is fitted on to a Mother Board. The Mother Board contains various components, which support the functioning of a PC.
b. It is brain of the computer
c. It is square shape
11. Ram Slots and Rams:
   a. Ram slots are used to install the rams
   b. It is large rectangle shape and each ending has small clips.
   c. There two type ram slots
   d. SD Ram;---------→Two Gaps
   e. DDR Ram--------→One Gap

12. North Bridge:
   a. It is also called as controller
   b. It converts electronic signals to binary values and binary values to electronic signals
   c. It is near by socket 478
   d. It placed middle of the mother board

13. South Bridge:
   a. It controls major components mother board and it back bone of the input out devices
   b. It is communicates PCI slots, IDE-1, IDE-2, floppy connecter, BIOS chip.
   c. It near by CMOS battery

14. CMOS Battery:
   a. Computer is using a coin shape battery
   b. It generates the clock signal and it manage system continues time
15. **Primary & Secondary (IDE-1 & IDE-2)**:
   a. It is also called as IDE-1, IDE-2.
   b. It used to connecting Hard Disk Drive, CD ROM, DVD ROM.

16. **Input & Output ports**:
   a. IO ports are used to connecting IO device such as key boards, mouse, monitor, printer, scanner, speakers etc...

17. **AGP Slot & AGP Card**:
   a. AGP Slot is used install the AGP card.
   b. AGP back view same as VGA port (15-female pins) and used to connecting the monitors
   c. This slot is above PCI slots and its color is Black or Brown

18. **CI Slots & PCI (Expansion) Cards**:
   a. PCI slots are used to install the PCI cards such as
      i. LAN (Ethernet) Card --- Back view Ethernet port
i. Sound Card → Back view Audio pin connectors)

iii. TV Tuner (Internal) Card → Dish Pin connector
b. PCI Slots are white or yellow color
c. PCI Card has Single gap only

19. **BIOS Chip** :
a. BIOS controls how the operating system and hardware work together
b. BIOS identification is BIOS name is available on chip or mother board

d.

20. **ATX Power connector**:
a. ATX power connector is used to connect ATX power plug (This is from SMPS)
b. ATX Power connector has 20/24 pins available.
c. It is white color and it has ATX name is available on Mother Board
e.

d.

21. **Floppy connector**:
a. Floppy connector is used to connect Floppy Disk Drive.
b. This is beside of ATX power connector and Name FDD is available on the mother board.
22. Bus Cables or Data cables:
   a. A Bus is a collection of wires through which data is transmitted from one device to another device cables are two types
   b. IDE cable: it used to connect HDD, CD ROM, DVD ROM
   c. FDD cable: it used to connect FDD (braking or manufacture defecting)

23. Hard Disk Drive:
   a. The hard disk drive is the main, and usually largest, data storage device in a computer
   b. The operating system, software titles and most other files are stored in the hard disk drive
   c. Identifications is the panel name is Hard Disk drive

24. CD ROM Drive & CD-Writer:
   a. CD-ROM (Compact Disk Read only Memory) Drive is a device that reads the information from Compact Disks (CD).
   b. CD-Writer is used to write the data into Compact Disks.
   c. Identification is the panel name is CD Writer

25. Floppy Disk Drive:
   a. The floppy disk drive is used to read the information stored in floppy disks.
   b. Floppy disks also called as a diskette.
   c. Identification is smaller than CD writer.

26. SMPS:
   a. SMPS is used to supply the power to Mother Board HDD, CD ROM, FDD
   b. In SMPS holds a transformer, voltage control and fan
   c. Identification is the rectangular box shape and panel name is switching mode power supply.
**TASK 2**

**Aim:** Assembling and disassembling the system hardware components of the personal computer

**Requirements:**

1. CPU (Processor)
2. Mother Board
3. Floppy Disk Drive
4. Hard Disk Drive
5. CD or DVD ROM
6. Cabinet
7. Speakers
8. Key Board
9. Mouse
10. Monitor
11. RAM (SD or DDR)
12. Bus Cables
13. Power Cables
14. SMPS
15. Screw Driver
16. Screws
17. Printer etc…

**Procedure:**

1. **Mother Board Installation:**
   
   a. Open the cabinet on either side.

   b. The back side of the cabinet has readymade provision for the installation of the I/O shields. An I/O shield is used for connecting the input and output devices through it.

   C. Check whether the mother board is placed in such a way that the I/O ports of the motherboard correctly fit in the I/O shields. Ensure all the specified screws for the motherboard are fixed and intact.

**CPU Installations:**

1. CPU is one of the most dedicated components of the computer. The CPU pins have to be clearly studied before fixing into the relevant processor space on the motherboard. After the CPU is rightly placed in its position the lever is to be locked.
2 As a part of the CPU installation, before the CPU is fixed in the right position a lever is provided, which needs to be unlocked. This lever is perpendicular to the motherboard.

3 The CPU, which is a square shaped electronic component, comes with pins below it. One should find for an indication on one of the corners of the CPU on both sides. This arrow mark is also found on the motherboard which guides for the fixation of the CPU. Once match of the pins versus motherboard slot gently push the CPU.

4 After the CPU is rightly placed in its position, the lever is to be locked.

CPU heat sink fan installation:

5 The CPU heat sink fan is to be carefully plugged on to the CPU by pushing down the metal plastic clips.

6 The metal/plastic clips provided with heat sink fan should fix on to the CPU socket and have to be locked.
7 Once the CPU heat sink fan is fixed and locked, it should be connected to the Power supply available on the motherboard through the power connector.

**RAM Installation:**
8 Next is installing the RAM. Insert the RAM into an available expansion socket. Note how the RAM is keyed to the socket. This ensures the RAM can be plugged into the socket one way only. Finally press the RAM firmly into position, making certain the Ram is completely seated in the socket.

**SMPS Installations:**
9 Next is installing the SMPS. This is an electronic power supply unit that provides and regulates the power supply to all components of a computer system. As shown in the diagram the SMPS needs to install into cabinet at the place provided for it.
10 After placing the SMPS into the relevant provider space fix the outer screws to it intact.

11 Next installing the ATX power connector. It is a 20/24-pin power connector. This is the primary power supply to the motherboard.
**Hard Disk Drive Installation:**

12 Installing the Hard Disk Drive (HDD) is clearly understood in the following steps. First see the rear of the HDD. It consists of the 3 types of pins. One left side the HDD has multiple pins termed as the IDE connector. In the middle is the jumper setting pins for the HDD. On the extreme right side is the power connector pins. Every device except FDD (floppy Disk Drive) uses this type of power connector. And HDD and CDD (Compact Disk Drive) connected by this type of IDE cable.

13 Mount the HDD into mounting slot meant for the HDD with the rear end facing and secure the inner screws intact.

14 Connect the IDE cable to the HDD as well as the mother board as shown in the figure.

15 Remember for all the power connectors to be plugged in, one needs to align the Red line on the cable to Pin-1 of the IDE port. Hence connect the power cable to the HDD rear end by gently pushing the connector.
**Floppy Disk Drive Installation:**

16. Installation of a Floppy Disk Drive (FDD) is very similar to the HDD installation. We need to identify the relevant pins for the motherboard and power supply connectivity. First Step in the FDD installation is mounting of the FDD into the FDD mounting slot by removing the cover of front side of the cabinet as shown in the figure below.

17. Push the FDD case into opened of the cabinet curtaining of the FDD

18. Secure FDD with inner screws.

19. Connect the one end of cable to mother board and other to end to FDD.

20. Connect the power connector to the FDD.
CD ROM Installation:

21 Next installing the CD-ROM. Remove the cover of front side of the cabinet curtaining of the CD-ROM.

22 Push CD-ROM case into opened space.

23 Secure CD-ROM with inner screws.

24 Connect the one end of cable to motherboard and another end to CD-ROM.

25 Connect the power connector to the CD-ROM.
Switches and LEDs Connections:
26 Installing the Switches and LEDs of front side of the cabinet. Please refer to your mother board manual to locate where the connectors are. Different mother boards place the connectors in different locations. The connectors for the switches and LEDs are normally grouped together. They should look similar to the figure given below.

IO Devices Installations:
27 Finally connect all peripheral devices like mouse, key-board, monitor, etc, to the I/O ports shown in the figure below.

a) Keyboard:
Keyboard has round shape connectors. The male connector appears at the edge of the keyboard’s cable and the female connector appears at the back side of the system unit. We are using the 6 pins round keyboard connector.

b) Mouse:
The mouse connector is same as the keyboard connector. The male connector appears at the edge of mouse cable and female connector appears at the backside of the system. It is also having 6 pins to connect the mouse.

c) Monitor:
The monitor of computer has ‘D’ shape connectors. The male Monitor connector has 15 pins and it appears at the edge of monitor’s cable. The female monitor connector appears at the back of the system unit.
d) Printer:

Printer connector is the oldest connector of a computer. The male printer connector has 25 pins and it appears at the edge of the printer cable and the backside of the system unit.

![Printer Connector Image]

e) Audio / Speaker:

For audio effect we are using speakers. The audio male connector have single thick pin and each male connector of individual speaker is distinguish with separate color. The male connectors appear at the edge of the speaker cables. The female audio connectors appear in same color at the back side of the system unit. The female audio connectors have some special symbols i.e.

1. The first symbol displays “line-out”.
2. The second symbol displays “line-in”.
3. The third symbol displays “Mic-in”.

Line-out ---------→ it sends the output to speakers.
Line-in----------→ it takes the input from speakers.
Mic-in ------→ it takes the input from microphone.

![Audio Connectors Image]

f) Ethernet / Networking:

The Ethernet connectors are used when two or more than two computers need to be linked with other over a computer network like LAN (local area network). The shape of male Ethernet connector is quite similar to male modem connector except it is more flat. The female Ethernet connector appears at the back of the system unit.

![Ethernet Connectors Image]

g) USB:

USB (universal serial bus) is the latest and most popular connector. Using USB connectors, we can connect so many different devices to our computer. Any device equipped with USB has slim male connector with slim metal coating appearing at the end of the devices cable. For connecting the device, a female USB connector is provided at the back of the system unit. We can identify the USB connector with this symbol.

![USB Connectors Image]
TASK 3:

Aim: Windows XP Installation Steps

Requirement:

1. Operating System CD
2. Computer

Procedure:

1. Insert the Windows XP CD-Rom and reboot the computer. If you see a message about hitting any key to boot the CD, do so now. Otherwise you will see a message about setup inspecting your system.

2. MS-DOS Portion of setup begins. In this setup first you will see a series of blue and gray MS-DOS based screens.

3. Welcome to setup. Finally setup begins. In this step you can setup XP, launch the recovery console, or quit. Press ENTER to continue the setup and it will examine your hard drives and removable disks.

4. Read the License agreement. Next you will have to agree to Microsoft license agreement. Then press F8 to continue the setup.

5. Choose an installation Partition. This crucial step lets you choose where to install XP. On a clean installation you will typically install to the C: Drive.
6. Select the file system. If you created a new partition of wish to change the file system of an existing partition you can do so in the next step. Generally speaking it is recommended to go with the NTFS file system.

7. Optionally format the partition. If you choose to change or format the file system, this will occur next. First you will be asked to verify the format. Press ENTER to continue and a yellow progress bar will indicate status of the format. When this complete, setup will again examine your disks and create a list of files to copy.

8. Setup folder copy phase and reboot. Setup will now copy system files to the system/ boot partition just you created. This will allow the PC to boot from the C: drive and continue setup in GUI mode. After coping the system will reboot. While rebooting it will show “Press any key to boot from CD” message again. This time do not press any key.

9. GUI setup begins. Once the system reboots you will be presented with the GUI setup phase. This could be taking several minutes

10. Regional and language options. In the first interactive portion of GUI setup, you can choose to customize the regional and
language settings. Click NEXT to Continue.

11. Personalize your software. Now enter your name and optionally your company name. Click NEXT to continue.

12. Enter your Product key. Now you must enter the 25 character product key. Then click NEXT to continue.

13. Enter a Computer Name and Administrator password. In the next phase of setup you can create a name for your computer. And optionally enter Administrator password. Then click NEXT to continue.

14. Supply your DATE and TIME settings. Next you can supply the date and time, which are auto set based on information in your BIOS. Click NEXT to continue.

15. Network Setup. If you have a networking card or modem, setup now installs the networking components.
16. Setup completion. From this point on setup will continue to completion without any further need for interaction. Setup will now copy files, complete installation, install your start menu items, register system component, save settings, remove any temporary files need to be setup. After system will again reboot. And while rebooting the system it will ask “Press any key to boot from CD” again. At this time also do not press any key.

17. First Reboot. You will be greeted by the XP splash screen on first boot.
18. Change Display settings. Users with CRT monitors or LCD monitors will see a display settings dialogue appear. It will ask you like to change your display settings automatically. Then Click OK and it will shows your screen with modified display settings and ask keep this settings for your computer. Press OK to continue.


20. Set up users. Now you can enter the at least one user name, that could be anything. And click NEXT to continue. After creating users it will shows FINISH button. Click that FINISH completing your XP installation.
SOFTWARE
LEAVE LETTER

Task 1:
Aim: Write a leave letter to the Principal by using different alignments, correct formats in MS-Word.

Procedure:
Step 1: Open MS-Word by click on START button: go to All Programs, then select Microsoft Office Word 2007.

Step 2: To open a new document, Click on Office Button then select New -> Blank Document then click on create option.

Step 3: Then select TEXT AREA, and then write Leave Letter as a heading. Select the text, click on bold button to make it bold as “LEAVE LETTER”, and change the font size to 16.

Step 4: Then write date and place in a format as follows
DATE: 05/01/2011,
Karimnagar.

Then Select the text and make it right by clicking on right alignment button

Step 5: Then write To address as follows and select this text and make it left by clicking on left alignment button

To,

The Principal,
Sree Chaitanya College of Engineering,
L.M.D. Colony,
Karimnagar.

Step 6: Then write Subject according to your letter. And select this text and press tab button for two times.

Step 7: Then write the body of the letter according to your letter. And select this text and make it justification by clicking on justify alignment button

Step 8: Then write “Thanking you Sir,” select this text and make it to center by clicking on center alignment button

Step 9: Now write the “From address” as follows
Yours Faithfully,
A. Ravi Kumar.

Then make it right by clicking on Right alignment button

Step 10: This is the final step in writing leave letter. In this step, we have to save the letter as “leave letter.doc” by selecting “Save” option from Office button. Then a prompt window will ask you to write a file name. Now you have to give the file name and press the save button.
VISITING CARD

Task 2:
Aim: Create a Visiting Card of your college using page size as follows
- Page width=”3.2”
- Page height=”2”

And use different font styles, sizes, alignments, and apply printed watermark on the paper.

Procedure:
Step 1: Open MS-Word by click on START button; go to All Programs, then select Microsoft Office Word 2007.
Step 2: To open a new document, Click on Office Button then select New -> Blank Document then click on create option.
Step 3: Now click on “Page Layout” from the Menu bar. Then click on Margins then click on Custom Margins option. Then the “Page Setup” dialog box appears. In this you find three tabs namely “Margins”, “Paper”, “Layout”. Then in the ‘Margins’ tab, make all the parameters like Top, Bottom, Left, Right, and Gutter to zero and make Gutter Position to Left. Then in the Page tab, change the width and height options to 3.2 and 2 respectively. Then in the Layout tab, make the Header and Footer to zero. Now this page is set to the visiting card as follows.

Step 4: In this step we have to enter the telephone number and Fax number on the top part of the paper. It can be done as follows:
- First go to Insert menu, then select Symbol option.
- Then change Font to “Windings”.
- Then select the appropriate to your need i.e., to the telephone option select ☎, and to the Fax option select 📡.

Step 5: Now write your institution name and make it to the center alignment button.
Step 6: Now write all the details you want to put in your visiting card as your needs. And select the text and make it to center.
Step 7: Now change the background color by selecting Page color option from Page Layout menu.
Step 8: Now insert printed Watermark option from the Page Layout menu which is in the Menu bar.
**Step 9:** This is the final step in writing leave letter. In this step, we have to save the letter as “leave letter.doc” by selecting “Save” option from Office button. Then a prompt window will ask you to write a file name. Now you have to give the file name and press the save button.
ID CARD

Task 3:
Aim: Create an Identity Card of your own which contains your own details by using different font styles, font colors, alignments and page size as follows
- Page width=”2”
- Page height=”3.2”

Procedure:
Step 1: Open MS-Word by click on START button; go to All Programs, then select Microsoft Office Word 2007.
Step 2: To open a new document, Click on Office Button then select New -> Blank Document then click on create option.
Step 3: Now click on “Page Layout” from the Menu bar. Then click on Margins then click on Custom Margins option.
Then the “Page Setup” dialog box appears. In this you find three tabs namely “Margins”, “Paper”, “Layout”. Then in the ‘Margins’ tab, make all the parameters like Top, Bottom, Left, Right, and Gutter to zero and make Gutter Position to Left. Then in the Page tab, change the width and height options to 2 and 3.2 respectively. Then in the Layout tab, make the Header and Footer to zero. Now this page is set to the visiting card as follows.

Step 4: In the text area type the text as “Sree Chaitanya College of Engineering” then select the text and change the font size to 18 and font to bold and make the text to center by clicking on center alignment button.

Step 5: Then in the next line type the texts as “Identity Card”, then select the text and apply the format as size 16 and font to Arial Bold.
Step 6: Draw a box for attesting photo by clicking on the Shapes button from Insert menu.
Step 7: After that in the next line type all your details as follows:

NAME:
FATHER’S NAME:

Then select the text and make it to Justify alignment.

Step 8: After that in the next line, type the text as “Principal” and make it to left alignment by clicking Left Alignment button. Then press tab for multiple times, then type the text as “Student’s Signature”.

Step 9: Then go to Page Layout menu - > Watermark then click on Custom watermark. Then Printed Watermark dialog box appears, then select Text Watermark radio button and write the “Text” as “SCCE”.

Step 10: At last we have to save the file as “Identity Card” by clicking on “Save” option from “Office” button.
MAIL MERGE

Task 4:
Aim: Create a mail merge to call 10 members for an interview.

Procedure:
Step 1: Open MS-Word by click on START button: go to All Programs, then select Microsoft Office Word 2007.

Step 2: To open a new document, Click on Office Button then select New - > Blank Document then click on create option.

Step 3: Select the text area, then write a letter with remaining the “To address” field empty.

Step 4: Select “Mailings” from “Tools’ menu. Then click on “Start Mail Merge” option then select “step by step Mail merge wizard…” Then Mail merge dialog box appears on the right side of the screen.

Step 5:
   i) Select the Letter Type as “Letters” Radio button from “Select document type list. Click on” Next: Starting document”.

   ii) Select the “Use the current document “radio button from the “select starting document “list. Then click on “Next: Select Recipients”

   iii) Select “Type a new list” radio button from “select recipients “list .Then click on “create”. Then a new dialogue box “New address list” appears. Then enter address information for 10 entries. Then click on “OK”. Then click on “save “. Then 10 entries list will appear, select needed ones. Then press on “OK”. Then click “Next: Write your letter”.

   iv) Select “More items”, then the list will appear. Then select need information and click on “Insert” -> ”Close” button as many as you want. Then click on “Next: Preview your letters”.

   v) We can preview of 10 letters by clicking on “Recipients” then click on “Next: Complete the merge”.

   vi) Select “Edit individual letters…” then select “All” Radio button then click “OK”, to edit any of the address if needed.

Step 6: At last we have to save the file as “Mail Merge” by clicking on: “Save” button from “Office” button.